CVE List

CVE-2019-18642

Critical 9.8

Rock RMS version before 8.6 is vulnerable to account takeover by tampering with the user ID parameter in the profile update feature. The lack of validation and use of sequential user IDs allows any user to change account details of any other user. This vulnerability could be used to change the email address of another account, even the administrator account. Upon changing another account's email address, performing a password reset to the new email address could allow an attacker to take over any account.

Published January 8, 2021.

Affected software

Sparkdevnetwork Rock Rms

Reference links

Sign Up for Alerts