CVE List

CVE-2019-20352

Critical 7.8

In Netwide Assembler (NASM) 2.15rc0, a heap-based buffer over-read occurs (via a crafted .asm file) in set_text_free when called from expand_one_smacro in asm/preproc.c.

Published January 6, 2020.

Affected software

Nasm Netwide Assembler

Reference links

Sign Up for Alerts