CVE List

CVE-2020-12038

Moderate 5.5

Products that use EDS Subsystem: Version 28.0.1 and prior (FactoryTalk Linx software (Previously called RSLinx Enterprise): Versions 6.00, 6.10, and 6.11, RSLinx Classic: Version 4.11.00 and prior, RSNetWorx software: Version 28.00.00 and prior, Studio 5000 Logix Designer software: Version 32 and prior) is vulnerable. A memory corruption vulnerability exists in the algorithm that matches square brackets in the EDS subsystem. This may allow an attacker to craft specialized EDS files to crash the EDSParser COM object, leading to denial-of-service conditions.

Published May 20, 2020.

Affected software

Rockwellautomation Rslinx

Rockwellautomation Rsnetworx

Rockwellautomation Eds Subsystem

Rockwellautomation Rslinx Enterprise

Rockwellautomation Studio 5000 Logix Designer

Reference links

Sign Up for Alerts