CVE List

CVE-2020-25695

Critical 8.8

A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Published November 16, 2020.

Affected software

Postgresql Postgresql

Reference links

Sign Up for Alerts