CVE List

CVE-2021-28940

Severe 9.8

Because of a incorrect escaped exec command in MagpieRSS in 0.72 in the /extlib/Snoopy.class.inc file, it is possible to add a extra command to the curl binary. This creates an issue on the /scripts/magpie_debug.php and /scripts/magpie_simple.php page that if you send a specific https url in the RSS URL field, you are able to execute arbitrary commands.

Published April 2, 2021.

Affected software

Magpierss Project Magpierss

Reference links

Sign Up for Alerts