ALPINE-CVE-2026-123158: High severity alpine/openssh vulnerability
sshd in OpenSSH before 10.6p2 on Linux, when musl libc is used without PAM, lacks a workaround for a password authentication bypass (related to misinterpretation of whether a string is intended to be a password hash). For some configurations of accounts, any password between 256 and 1024 characters succeeds. An example of a platform using musl libc without PAM is Alpine Linux.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.0_p1-r6 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.1_p1-r7 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.3_p2-r4 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.6_p1-r3 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.7_p1-r6 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 9.9_p2-r1 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 10.0_p1-r11 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 10.2_p1-r1 - Upgrade
Upgrade
alpine/opensshto a version that resolves this vulnerability.Fixed in 10.3_p1-r2 - Upgrade
Upgrade
OpenSSH sshdto a version that resolves this vulnerability.Fixed in 10.6p2