AZL-111518: CVE-2026-111497 affecting package p7zip 16.02-23

Published Oct 22, 2026
·
Updated

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Affected Software

1 affected component
azure-linux/p7zip<=16.02-23

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Brotli to a version that resolves this vulnerability.

    Fixed in 1.0.10
  2. Upgrade

    Upgrade Google Brotli to a version that resolves this vulnerability.

    Fixed in 1.1.1
  3. Upgrade

    Upgrade Google Brotli to a version that resolves this vulnerability.

    Fixed in 1.2.1

Event History

Oct 22, 2026
Advisory Published
via OSV·02:17 PM
Data Sourced
via OSV·02:17 PM
DescriptionAffected Software

Child vulnerabilities

Contains the following vulnerabilities.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203