AZL-112700: CVE-2026-61813 affecting package mod_security 2.9.7-8
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Prior to 2.9.15 and 3.0.17, the HttpsClient::download function in src/utils/httpsclient.cc sets libcurl CURLOPTSSLVERIFYHOST to 1 instead of the strict value 2L. Under adversary-in-the-middle and TLS interception conditions, this non-strict setting may weaken TLS peer identity validation and increase the risk of accepting a certificate for an unintended host. End-to-end exploitation is non-trivial in typical environments. This issue is fixed in versions 2.9.15 and 3.0.17.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
mod_securityto a version that resolves this vulnerability.Fixed in 2.9.15 - Upgrade
Upgrade
mod_securityto a version that resolves this vulnerability.Fixed in 3.0.17