BIT-brotli-2026-111497: Out-of-Bounds Write in Google Brotli Decoder

Published Oct 22, 2026
·
Updated

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.

Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Other sources

A flaw in Node.js can cause Node.js Brotli decoder out-of-bounds write permits remote code execution. This vulnerability affects Node.js 22.x, 24.x, and 26.x.

— OSV

CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous value for an invalid block switch, and the fast decode path discards it (CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder continue on corrupted state and write past the ring buffer. Upstream rates it CVSS 4.0 9.2 and classifies the impact as potential remote code execution.

The vulnerability is in Google's C library, not in Node.js specifically. The PyPI Brotli package is Google's CPython binding and compiles the same c/dec/decode.c that has the actual vulnerability. All Brotli releases up to and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version bump.

The decoder is reached whenever untrusted Brotli data is decompressed. With Brotli installed, common HTTP clients decode Brotli responses automatically (urllib3/requests, httpx with the brotli extra, aiohttp) and services that accept Content-Encoding: br request bodies decode inbound data, so the flaw is reachable from attacker-controlled input.

— OSV

CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous value for an invalid block switch, and the fast decode path discards it (CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder continue on corrupted state and write past the ring buffer. Upstream rates it CVSS 4.0 9.2 and classifies the impact as potential remote code execution.

The vulnerability is in Google's C library, not in Node.js specifically. The PyPI Brotli package is Google's CPython binding and compiles the same c/dec/decode.c that has the original vulnerability. All Brotli releases up to and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version bump.

The decoder is reached whenever untrusted Brotli data is decompressed. With brotlicffi installed, common HTTP clients decode Brotli responses automatically (urllib3/requests, httpx with the brotli extra, aiohttp) and services that accept Content-Encoding: br request bodies decode inbound data, so the flaw is reachable from attacker-controlled input.

— OSV

Affected Software

22 affected componentsFixes available
bitnami/brotli>=1.0.3<1.0.10
1.0.10
bitnami/brotli>=1.1.0<1.1.1
1.1.1
bitnami/brotli>=1.2.0<1.2.1
1.2.1
bitnami/dotnet-sdk>=8.0.0<8.0.33
8.0.33
bitnami/dotnet-sdk>=9.0.0<9.0.22
9.0.22
bitnami/dotnet-sdk>=10.0.0<10.0.14
10.0.14
bitnami/dotnet>=8.0.0<8.0.33
8.0.33
bitnami/dotnet>=9.0.0<9.0.22
9.0.22
bitnami/dotnet>=10.0.0<10.0.14
10.0.14
bitnami/node<22.23.4
22.23.4
bitnami/node>=23.0.0<24.22.1
24.22.1
bitnami/node>=26.0.0<26.12.1
26.12.1
bitnami/node-min<22.23.4
22.23.4
bitnami/node-min>=23.0.0<24.22.1
24.22.1
bitnami/node-min>=26.0.0<26.12.1
26.12.1
bitnami/powershell>=7.4.0<7.4.22
7.4.22
bitnami/powershell>=7.5.0<7.5.13
7.5.13
bitnami/powershell>=7.6.0<7.6.9
7.6.9
pip/brotli>=1.0.3<1.2.1
1.2.1
pip/brotlicffi>=1.0.3<1.2.1.0
1.2.1.0
pip/brotli<1.2.1
1.2.1
pip/brotlicffi<1.2.1.0
1.2.1.0

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade bitnami/brotli to a version that resolves this vulnerability.

    Fixed in 1.0.10
  2. Upgrade

    Upgrade bitnami/brotli to a version that resolves this vulnerability.

    Fixed in 1.1.1
  3. Upgrade

    Upgrade bitnami/brotli to a version that resolves this vulnerability.

    Fixed in 1.2.1
  4. Upgrade

    Upgrade bitnami/dotnet-sdk to a version that resolves this vulnerability.

    Fixed in 8.0.33
  5. Upgrade

    Upgrade bitnami/dotnet-sdk to a version that resolves this vulnerability.

    Fixed in 9.0.22
  6. Upgrade

    Upgrade bitnami/dotnet-sdk to a version that resolves this vulnerability.

    Fixed in 10.0.14
  7. Upgrade

    Upgrade bitnami/dotnet to a version that resolves this vulnerability.

    Fixed in 8.0.33
  8. Upgrade

    Upgrade bitnami/dotnet to a version that resolves this vulnerability.

    Fixed in 9.0.22
  9. Upgrade

    Upgrade bitnami/dotnet to a version that resolves this vulnerability.

    Fixed in 10.0.14
  10. Upgrade

    Upgrade bitnami/node to a version that resolves this vulnerability.

    Fixed in 22.23.4
  11. Upgrade

    Upgrade bitnami/node to a version that resolves this vulnerability.

    Fixed in 24.22.1
  12. Upgrade

    Upgrade bitnami/node to a version that resolves this vulnerability.

    Fixed in 26.12.1
  13. Upgrade

    Upgrade bitnami/node-min to a version that resolves this vulnerability.

    Fixed in 22.23.4
  14. Upgrade

    Upgrade bitnami/node-min to a version that resolves this vulnerability.

    Fixed in 24.22.1
  15. Upgrade

    Upgrade bitnami/node-min to a version that resolves this vulnerability.

    Fixed in 26.12.1
  16. Upgrade

    Upgrade bitnami/powershell to a version that resolves this vulnerability.

    Fixed in 7.4.22
  17. Upgrade

    Upgrade bitnami/powershell to a version that resolves this vulnerability.

    Fixed in 7.5.13
  18. Upgrade

    Upgrade bitnami/powershell to a version that resolves this vulnerability.

    Fixed in 7.6.9
  19. Upgrade

    Upgrade pip/brotli to a version that resolves this vulnerability.

    Fixed in 1.2.1
  20. Upgrade

    Upgrade pip/brotlicffi to a version that resolves this vulnerability.

    Fixed in 1.2.1.0
  21. Upgrade

    Upgrade Google Brotli to a version that resolves this vulnerability.

    Fixed in 1.2.1

Event History

Oct 22, 2026
CVE Published
via OSV·01:35 PM
Data Sourced
via OSV·01:35 PM
DescriptionSeverityWeakness
Advisory Published
via OSV·03:32 PM
Data Sourced
via OSV·03:32 PM
Affected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203