BIT-php-2026-109619: RCE via stale global state

Published Oct 22, 2026
·
Updated

PHP has various global state that temporarily points into request memory. In some scenarios, global state may not be correctly reset, or may be repopulated after being reset. The global state may then refer to request memory even after it has been freed. Subsequent requests may read or branch on this stale state before it is fully initialized. Multiple strategies can trigger this condition and produce remote code execution (RCE).

Affected Software

12 affected componentsFixes available
bitnami/libphp>=5.4.0<8.2.35
8.2.35
bitnami/libphp>=8.3.0<8.3.36
8.3.36
bitnami/libphp>=8.4.0<8.4.27
8.4.27
bitnami/libphp>=8.5.0<8.5.12
8.5.12
bitnami/php>=5.4.0<8.2.35
8.2.35
bitnami/php>=8.3.0<8.3.36
8.3.36
bitnami/php>=8.4.0<8.4.27
8.4.27
bitnami/php>=8.5.0<8.5.12
8.5.12
bitnami/php-min>=5.4.0<8.2.35
8.2.35
bitnami/php-min>=8.3.0<8.3.36
8.3.36
bitnami/php-min>=8.4.0<8.4.27
8.4.27
bitnami/php-min>=8.5.0<8.5.12
8.5.12

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade bitnami/libphp to a version that resolves this vulnerability.

    Fixed in 8.2.35
  2. Upgrade

    Upgrade bitnami/libphp to a version that resolves this vulnerability.

    Fixed in 8.3.36
  3. Upgrade

    Upgrade bitnami/libphp to a version that resolves this vulnerability.

    Fixed in 8.4.27
  4. Upgrade

    Upgrade bitnami/libphp to a version that resolves this vulnerability.

    Fixed in 8.5.12
  5. Upgrade

    Upgrade bitnami/php to a version that resolves this vulnerability.

    Fixed in 8.2.35
  6. Upgrade

    Upgrade bitnami/php to a version that resolves this vulnerability.

    Fixed in 8.3.36
  7. Upgrade

    Upgrade bitnami/php to a version that resolves this vulnerability.

    Fixed in 8.4.27
  8. Upgrade

    Upgrade bitnami/php to a version that resolves this vulnerability.

    Fixed in 8.5.12
  9. Upgrade

    Upgrade bitnami/php-min to a version that resolves this vulnerability.

    Fixed in 8.2.35
  10. Upgrade

    Upgrade bitnami/php-min to a version that resolves this vulnerability.

    Fixed in 8.3.36
  11. Upgrade

    Upgrade bitnami/php-min to a version that resolves this vulnerability.

    Fixed in 8.4.27
  12. Upgrade

    Upgrade bitnami/php-min to a version that resolves this vulnerability.

    Fixed in 8.5.12

Event History

Oct 22, 2026
Advisory Published
via OSV·08:04 AM
Data Sourced
via OSV·08:04 AM
DescriptionSeverityAffected Software

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203