BIT-powershell-2026-111497: Out-of-Bounds Write in Google Brotli Decoder
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
Other sources
A flaw in Node.js can cause Node.js Brotli decoder out-of-bounds write permits remote code execution. This vulnerability affects Node.js 22.x, 24.x, and 26.x.
— OSV
CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous value for an invalid block switch, and the fast decode path discards it (CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder continue on corrupted state and write past the ring buffer. Upstream rates it CVSS 4.0 9.2 and classifies the impact as potential remote code execution.
The vulnerability is in Google's C library, not in Node.js specifically. The PyPI Brotli package is Google's CPython binding and compiles the same c/dec/decode.c that has the actual vulnerability. All Brotli releases up to and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version bump.
The decoder is reached whenever untrusted Brotli data is decompressed. With Brotli installed, common HTTP clients decode Brotli responses automatically (urllib3/requests, httpx with the brotli extra, aiohttp) and services that accept Content-Encoding: br request bodies decode inbound data, so the flaw is reachable from attacker-controlled input.
— OSV
CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous value for an invalid block switch, and the fast decode path discards it (CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder continue on corrupted state and write past the ring buffer. Upstream rates it CVSS 4.0 9.2 and classifies the impact as potential remote code execution.
The vulnerability is in Google's C library, not in Node.js specifically. The PyPI Brotli package is Google's CPython binding and compiles the same c/dec/decode.c that has the original vulnerability. All Brotli releases up to and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version bump.
The decoder is reached whenever untrusted Brotli data is decompressed. With brotlicffi installed, common HTTP clients decode Brotli responses automatically (urllib3/requests, httpx with the brotli extra, aiohttp) and services that accept Content-Encoding: br request bodies decode inbound data, so the flaw is reachable from attacker-controlled input.
— OSV
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
bitnami/brotlito a version that resolves this vulnerability.Fixed in 1.0.10 - Upgrade
Upgrade
bitnami/brotlito a version that resolves this vulnerability.Fixed in 1.1.1 - Upgrade
Upgrade
bitnami/brotlito a version that resolves this vulnerability.Fixed in 1.2.1 - Upgrade
Upgrade
bitnami/dotnet-sdkto a version that resolves this vulnerability.Fixed in 8.0.33 - Upgrade
Upgrade
bitnami/dotnet-sdkto a version that resolves this vulnerability.Fixed in 9.0.22 - Upgrade
Upgrade
bitnami/dotnet-sdkto a version that resolves this vulnerability.Fixed in 10.0.14 - Upgrade
Upgrade
bitnami/dotnetto a version that resolves this vulnerability.Fixed in 8.0.33 - Upgrade
Upgrade
bitnami/dotnetto a version that resolves this vulnerability.Fixed in 9.0.22 - Upgrade
Upgrade
bitnami/dotnetto a version that resolves this vulnerability.Fixed in 10.0.14 - Upgrade
Upgrade
bitnami/nodeto a version that resolves this vulnerability.Fixed in 22.23.4 - Upgrade
Upgrade
bitnami/nodeto a version that resolves this vulnerability.Fixed in 24.22.1 - Upgrade
Upgrade
bitnami/nodeto a version that resolves this vulnerability.Fixed in 26.12.1 - Upgrade
Upgrade
bitnami/node-minto a version that resolves this vulnerability.Fixed in 22.23.4 - Upgrade
Upgrade
bitnami/node-minto a version that resolves this vulnerability.Fixed in 24.22.1 - Upgrade
Upgrade
bitnami/node-minto a version that resolves this vulnerability.Fixed in 26.12.1 - Upgrade
Upgrade
bitnami/powershellto a version that resolves this vulnerability.Fixed in 7.4.22 - Upgrade
Upgrade
bitnami/powershellto a version that resolves this vulnerability.Fixed in 7.5.13 - Upgrade
Upgrade
bitnami/powershellto a version that resolves this vulnerability.Fixed in 7.6.9 - Upgrade
Upgrade
pip/brotlito a version that resolves this vulnerability.Fixed in 1.2.1 - Upgrade
Upgrade
pip/brotlicffito a version that resolves this vulnerability.Fixed in 1.2.1.0 - Upgrade
Upgrade
Google Brotlito a version that resolves this vulnerability.Fixed in 1.2.1
Event History
Frequently Asked Questions
Which deployments are realistically exposed?
Any deployment on any platform that uses an affected Brotli decoder to process attacker-controlled Brotli-compressed streams is exposed. The affected software list includes Bitnami Brotli, .NET SDK, .NET, Node, Node-min, and PowerShell packages, plus the pip Brotli and Brotlicffi packages.
What does an attacker need to exploit this issue?
An attacker can exploit the flaw remotely without authentication by supplying a crafted Brotli-compressed stream to a vulnerable decoder. No user interaction is required.
How can I determine whether my environment is affected?
Inventory Brotli libraries and binaries, including Brotli dependencies bundled with applications or runtimes. Versions from 1.0.3 through 1.2.0 are identified as affected; the available information also identifies Node.js 22.x, 24.x, and 26.x as affected.
What should be done if affected software is found?
Update affected Brotli libraries or binaries to the latest available fixed version identified in the advisory: 1.0.10, 1.1.1, or 1.2.1. Prioritize systems that decode Brotli data received from remote or untrusted sources.