BIT-tomcat-2026-101296: Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms

Published Oct 29, 2026
·
Updated

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password.

This issue affects Apache Tomcat: from 11.0.0 through 11.0.26, from 10.1.0 through 10.1.60, from 9.0.0 through 9.0.122.

The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected.

Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Affected Software

3 affected componentsFixes available
bitnami/tomcat>=7.0.0<9.0.123
9.0.123
bitnami/tomcat>=10.1.0<10.1.61
10.1.61
bitnami/tomcat>=11.0.0<11.0.27
11.0.27

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade bitnami/tomcat to a version that resolves this vulnerability.

    Fixed in 9.0.123
  2. Upgrade

    Upgrade bitnami/tomcat to a version that resolves this vulnerability.

    Fixed in 10.1.61
  3. Upgrade

    Upgrade bitnami/tomcat to a version that resolves this vulnerability.

    Fixed in 11.0.27
  4. Upgrade

    Upgrade Apache Tomcat to a version that resolves this vulnerability.

    Fixed in 11.0.27
  5. Upgrade

    Upgrade Apache Tomcat to a version that resolves this vulnerability.

    Fixed in 10.1.61
  6. Upgrade

    Upgrade Apache Tomcat to a version that resolves this vulnerability.

    Fixed in 9.0.123

Event History

Oct 29, 2026
Advisory Published
via OSV·09:01 AM
Data Sourced
via OSV·09:01 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

Which deployments are exposed to this issue?

Deployments are affected when Apache Tomcat uses the JNDI realm configured with a non-GSSAPI SASL authentication mechanism. Tomcat installations not using that realm configuration are not identified as affected by the provided information.

2

What does an attacker need to exploit the vulnerability?

An attacker can authenticate without supplying the correct password when the affected JNDI realm configuration is in use. No privileges or user interaction are indicated by the supplied severity vector.

3

Are default Tomcat deployments affected?

The issue depends on configuring the JNDI realm with a non-GSSAPI SASL mechanism. The provided information does not state that this is enabled by default.

4

What versions should be used to remediate the issue?

Upgrade to Apache Tomcat 11.0.27, 10.1.61, or 9.0.123. Affected supported ranges are 11.0.0 through 11.0.26, 10.1.0 through 10.1.60, and 9.0.0 through 9.0.122; listed EOL ranges are also known to be affected.

5

How can I determine whether my deployment needs immediate remediation?

Check both the Tomcat version and realm configuration. Immediate remediation is needed if the deployment is within an affected range and its JNDI realm uses a non-GSSAPI SASL authentication mechanism.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203