CVE-2007-5208: Input Validation

Published Oct 5, 2007
·
Updated

hpssd in Hewlett-Packard Linux Imaging and Printing Project (hplip) 1.x and 2.x before 2.7.10 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in a from address, which is not properly handled when invoking sendmail.

Other sources

Kees Cook of the Ubuntu Security Team has informed us of following security vulnerability in hplip:

I just discovered that the hpssd daemon of hplip is vulnerable to arbitrary command injection via its use of popen3. Other local users can run commands as the invoker of hpssd (usually root, hplip, or a local user). By default, it only listens on localhost, but this is configurable via /etc/hp/hplip.conf, so in the worst-case it is possible this could allow remote root command execution.

Both 2.x and 1.x series appear vulnerable (but not 0.x which used SMTP).

The bug for this is: https://launchpad.net/bugs/149121

— Red Hat

Affected Software

5 affected componentsFixes available
HP Linux Imaging and Printing Project=1.0
HP Linux Imaging and Printing Project<=2.7.10
debian/hplip<1.6.10-4.3
1.6.10-4.3
debian/hplip<1.6.10-4.3
1.6.10-4.3
debian/hplip
3.22.10+dfsg0-23.22.10+dfsg0-2+deb12u13.22.10+dfsg0-8.1+deb13u13.26.4+dfsg0-4

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade debian/hplip to a version that resolves this vulnerability.

    Fixed in 1.6.10-4.3
  2. Upgrade

    Upgrade debian/hplip to a version that resolves this vulnerability.

    Fixed in 3.22.10+dfsg0-2Fixed in 3.22.10+dfsg0-2+deb12u1Fixed in 3.22.10+dfsg0-8.1+deb13u1Fixed in 3.26.4+dfsg0-4
  3. Upgrade

    Upgrade hplip to a version that resolves this vulnerability.

    Fixed in 2.7.10

Event History

Oct 5, 2007
Data Sourced
via Red Hat·10:16 AM
DescriptionSeverityAffected Software
Oct 13, 2007
CVE Published
12:17 AM
Data Sourced
via OSV·12:17 AM
DescriptionAffected Software
CVE Published
via MITRE·04:00 AM
Data Sourced
via MITRE·04:00 AM
Description

Parent advisories

This vulnerability appears in the following advisories.

Peer vulnerabilities

Found alongside the following vulnerabilities.

Frequently Asked Questions

1

What is the severity of CVE-2007-5208?

CVE-2007-5208 is classified as a medium-severity vulnerability.

2

How do I fix CVE-2007-5208?

To fix CVE-2007-5208, upgrade to HP Linux Imaging and Printing Project version 2.7.10 or later.

3

What systems are affected by CVE-2007-5208?

CVE-2007-5208 affects versions of HP Linux Imaging and Printing Project 1.x and 2.x before 2.7.10.

4

What type of vulnerability is CVE-2007-5208?

CVE-2007-5208 is a command execution vulnerability due to improper handling of shell metacharacters.

5

Can CVE-2007-5208 be exploited remotely?

Yes, CVE-2007-5208 can be exploited by context-dependent attackers through crafted email addresses.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203