CVE-2008-1980: XSS
Published Apr 27, 2008
·Updated
Cross-site scripting (XSS) vulnerability in E-Publish 5.x before 5.x-1.1 and 6.x before 6.x-1.0 beta1, a Drupal module, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected Software
3 affected components
Drupal Drupal<=5.0
Drupal E-Publish<=5-1.1
Drupal E-Publish<=6-1.0
Remediation
Patch Available
Event History
Apr 27, 2008
CVE Published
via MITRE·08:00 PM
Data Sourced
via MITRE·08:00 PM
Description
Data Sourced
08:05 PM
DescriptionWeaknessAffected Software
Frequently Asked Questions
1
What is the severity of CVE-2008-1980?
CVE-2008-1980 has a moderate severity due to its potential for cross-site scripting attacks.
2
How do I fix CVE-2008-1980?
To fix CVE-2008-1980, update E-Publish to version 5.x-1.1 or 6.x-1.0 beta1 or later.
3
What types of attacks can CVE-2008-1980 facilitate?
CVE-2008-1980 can facilitate cross-site scripting (XSS) attacks, allowing attackers to inject malicious scripts into web pages.
4
Which versions of E-Publish are affected by CVE-2008-1980?
CVE-2008-1980 affects E-Publish versions prior to 5.x-1.1 and 6.x-1.0 beta1.
5
Can CVE-2008-1980 be exploited remotely?
Yes, CVE-2008-1980 allows remote attackers to exploit the vulnerability without local access.