CVE-2008-4790: Medium severity drupal vulnerability
Published Oct 29, 2008
·Updated
The core upload module in Drupal 5.x before 5.11 allows remote authenticated users to bypass intended access restrictions and read "files attached to content" via unknown vectors.
Affected Software
15 affected components
Drupal Drupal<=5.10
Drupal Drupal=5.0
Drupal Drupal=5.0-beta1
Drupal Drupal=5.0-beta2
Drupal Drupal=5.0-rc1
Drupal Drupal=5.0-rc2
Drupal Drupal=5.1
Drupal Drupal=5.2
Drupal Drupal=5.3
Drupal Drupal=5.4
Drupal Drupal=5.5
Drupal Drupal=5.6
Drupal Drupal=5.7
Drupal Drupal=5.8
Drupal Drupal=5.9
Remediation
Patch Available
Event History
Oct 29, 2008
CVE Published
via MITRE·03:00 PM
Data Sourced
via MITRE·03:00 PM
Description
Frequently Asked Questions
1
What is the severity of CVE-2008-4790?
CVE-2008-4790 has been classified with a medium severity level due to its potential for allowing unauthorized access to sensitive files.
2
How do I fix CVE-2008-4790?
To fix CVE-2008-4790, upgrade your Drupal installation to version 5.11 or later.
3
Who is affected by CVE-2008-4790?
CVE-2008-4790 affects all users of Drupal versions 5.x prior to 5.11 that have the core upload module enabled.
4
What kind of access does CVE-2008-4790 allow?
CVE-2008-4790 allows remote authenticated users to bypass access restrictions and read attached files.
5
Is CVE-2008-4790 a public vulnerability?
Yes, CVE-2008-4790 is a publicly disclosed vulnerability that can be exploited by users with certain privileges.