CVE-2008-6909: Medium severity marc ingram services vulnerability
Services 5.x before 5.x-0.92 and 6.x before 6.x-0.13, a module for Drupal, does not sign all required data in requests, which has unspecified impact, probably related to man-in-the-middle attacks that modify critical data and allow remote attackers to impersonate other users and gain privileges.
Affected Software
Remediation
Patch Available
Patch Available
Patch Available
Event History
Frequently Asked Questions
What is the severity of CVE-2008-6909?
CVE-2008-6909 has a severity rating that suggests a potential for serious exploitation, particularly related to man-in-the-middle attacks.
How do I fix CVE-2008-6909?
To fix CVE-2008-6909, update the Services module to versions 5.x-0.92 or 6.x-0.13 and later.
What versions are affected by CVE-2008-6909?
CVE-2008-6909 affects Services versions 5.x before 5.x-0.92 and 6.x before 6.x-0.13.
What impacts can arise from CVE-2008-6909?
CVE-2008-6909 can allow remote attackers to impersonate users and gain privileges due to inadequate signing of request data.
Is my Drupal installation vulnerable to CVE-2008-6909?
If you are using Services module versions 5.x-0.9, 5.x-0.91, 5.x-1.x-dev, 6.x-0.9, 6.x-0.11, 6.x-0.12, or 6.x-1.x-dev, your Drupal installation is vulnerable.