CVE-2009-3374: High severity firefox vulnerability
The XPCVariant::VariantDataToJS function in the XPCOM implementation in Mozilla Firefox 3.0.x before 3.0.15 and 3.5.x before 3.5.4 does not enforce intended restrictions on interaction between chrome privileged code and objects obtained from remote web sites, which allows remote attackers to execute arbitrary JavaScript with chrome privileges via unspecified method calls, related to "doubly-wrapped objects."
Affected Software
Remediation
Event History
Frequently Asked Questions
What is the severity of CVE-2009-3374?
CVE-2009-3374 has a severity rating of high due to its potential for remote code execution.
How do I fix CVE-2009-3374?
To fix CVE-2009-3374, users should update to Mozilla Firefox version 3.0.15 or 3.5.4 or later.
What versions of Firefox are affected by CVE-2009-3374?
CVE-2009-3374 affects Mozilla Firefox versions 3.0.x prior to 3.0.15 and 3.5.x prior to 3.5.4.
What type of vulnerability is CVE-2009-3374?
CVE-2009-3374 is a security vulnerability that allows remote attackers to execute arbitrary code.
Is there a workaround for CVE-2009-3374?
There are no known effective workarounds for CVE-2009-3374, so updating is strongly recommended.