CVE-2010-3660: TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows XSS on the backend.
Other sources
TYPO3 is vulnerable to Cross-Site Scripting (XSS) on the backend
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.4.1 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.3.4 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.2.13 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.1.14
Event History
Frequently Asked Questions
What is the severity of CVE-2010-3660?
CVE-2010-3660 has been classified with a severity level that makes it a significant threat due to its potential to allow XSS attacks.
How do I fix CVE-2010-3660?
To resolve CVE-2010-3660, upgrade to TYPO3 version 4.4.1, 4.3.4, 4.2.13, or 4.1.14.
What types of attacks are possible due to CVE-2010-3660?
CVE-2010-3660 allows attackers to execute cross-site scripting (XSS) attacks within the TYPO3 backend.
Which TYPO3 versions are affected by CVE-2010-3660?
CVE-2010-3660 affects TYPO3 versions prior to 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4, and 4.4.x before 4.4.1.
Are there any known exploits for CVE-2010-3660?
Yes, CVE-2010-3660 has been publicly reported and there are known exploits that utilize the XSS vulnerability.