CVE-2010-3662: TYPO3 SQL injection vulnerability on the backend
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 allows SQL Injection on the backend.
Other sources
TYPO3 SQL injection vulnerability on the backend
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.4.1 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.3.4 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.2.13 - Upgrade
Upgrade
composer/typo3/cms-backendto a version that resolves this vulnerability.Fixed in 4.1.14
Event History
Frequently Asked Questions
What is the severity of CVE-2010-3662?
CVE-2010-3662 has been classified as a medium severity vulnerability due to its potential for SQL Injection.
How do I fix CVE-2010-3662?
To fix CVE-2010-3662, update TYPO3 to version 4.1.14 or higher, 4.2.13 or higher, 4.3.4 or higher, or 4.4.1.
Which TYPO3 versions are affected by CVE-2010-3662?
CVE-2010-3662 affects TYPO3 versions prior to 4.1.14, 4.2.13, 4.3.4, and 4.4.1.
What type of vulnerability is CVE-2010-3662 classified as?
CVE-2010-3662 is classified as an SQL Injection vulnerability in the TYPO3 backend.
Is there any workaround for CVE-2010-3662?
There are no known workarounds for CVE-2010-3662; updating to a fixed version is recommended.