CVE-2010-3663: TYPO3 Arbitrary Code Execution vulnerability on the backend

Published Nov 4, 2019
·
Updated

TYPO3 Arbitrary Code Execution vulnerability on the backend

Other sources

TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 contains an insecure default value of the variable fileDenyPattern which could allow remote attackers to execute arbitrary code on the backend.

— GitHub

Affected Software

13 affected componentsFixes available
composer/typo3/cms-backend>=4.4<4.4.1
4.4.1
composer/typo3/cms-backend>=4.3<4.3.4
4.3.4
composer/typo3/cms-backend>=4.2<4.2.13
4.2.13
composer/typo3/cms-backend<4.1.14
4.1.14
debian/typo3-src
Typo3 TYPO3>=4.4.0<4.4.1
Typo3 TYPO3>=4.3.0<4.3.4
Typo3 TYPO3<4.1.14
Typo3 TYPO3>=4.2.0<4.2.13
composer/typo3/cms-backend>=4.4, <4.4.1
4.4.1
composer/typo3/cms-backend>=4.3, <4.3.4
4.3.4
composer/typo3/cms-backend>=4.2, <4.2.13
4.2.13
composer/typo3/cms-backend<4.1.14
4.1.14

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/typo3/cms-backend to a version that resolves this vulnerability.

    Fixed in 4.4.1
  2. Upgrade

    Upgrade composer/typo3/cms-backend to a version that resolves this vulnerability.

    Fixed in 4.3.4
  3. Upgrade

    Upgrade composer/typo3/cms-backend to a version that resolves this vulnerability.

    Fixed in 4.2.13
  4. Upgrade

    Upgrade composer/typo3/cms-backend to a version that resolves this vulnerability.

    Fixed in 4.1.14

Event History

Nov 4, 2019
CVE Published
via MITRE·09:18 PM
Data Sourced
via MITRE·09:18 PM
Description
Data Sourced
via NVD·10:15 PM
DescriptionSeverityWeaknessAffected Software
Apr 21, 2022
Advisory Published
via GitHub·01:57 AM
Data Sourced
via GitHub·01:57 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·01:57 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2010-3663?

CVE-2010-3663 is a vulnerability in TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4, and 4.4.x before 4.4.1 that allows remote attackers to execute arbitrary code on the backend.

2

How severe is CVE-2010-3663?

CVE-2010-3663 has a severity score of 8.8 out of 10.

3

What is the affected software for CVE-2010-3663?

The affected software for CVE-2010-3663 is TYPO3 versions before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4, and 4.4.x before 4.4.1.

4

How can I fix CVE-2010-3663?

To fix CVE-2010-3663, update TYPO3 to version 4.1.14, 4.2.13, 4.3.4, or 4.4.1.

5

Where can I find more information about CVE-2010-3663?

You can find more information about CVE-2010-3663 at the TYPO3 security advisory and Debian security tracker websites.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203