CVE-2010-3671: TYPO3 is vulnerable to Session Fixation
TYPO3 before 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4 and 4.4.x before 4.4.1 is open to a session fixation attack which allows remote attackers to hijack a victim's session.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-installto a version that resolves this vulnerability.Fixed in 4.4.1 - Upgrade
Upgrade
composer/typo3/cms-installto a version that resolves this vulnerability.Fixed in 4.3.4 - Upgrade
Upgrade
composer/typo3/cms-installto a version that resolves this vulnerability.Fixed in 4.2.13 - Upgrade
Upgrade
composer/typo3/cms-installto a version that resolves this vulnerability.Fixed in 4.1.14 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.1.14 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.2.13 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.3.4 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.4.1
Event History
Frequently Asked Questions
What is the severity of CVE-2010-3671?
CVE-2010-3671 has a high severity due to the potential for session fixation attacks that can lead to session hijacking.
How do I fix CVE-2010-3671?
To fix CVE-2010-3671, upgrade TYPO3 to version 4.4.1 or later, 4.3.4 or later, 4.2.13 or later, or 4.1.14.
What versions of TYPO3 are affected by CVE-2010-3671?
CVE-2010-3671 affects TYPO3 versions prior to 4.1.14, 4.2.x before 4.2.13, 4.3.x before 4.3.4, and 4.4.x before 4.4.1.
What type of vulnerability is CVE-2010-3671?
CVE-2010-3671 is a vulnerability that allows session fixation attacks, enabling attackers to hijack user sessions.
Is CVE-2010-3671 a critical vulnerability in TYPO3?
Yes, CVE-2010-3671 is considered critical as it poses a significant risk of session hijacking for web applications using vulnerable versions of TYPO3.