CVE-2010-3672: TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper
TYPO3 before 4.3.4 and 4.4.x before 4.4.1 allows XSS in the textarea view helper in an extbase extension.
Other sources
TYPO3 vulnerable to Cross-Site Scripting in the textarea view helper
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-fluidto a version that resolves this vulnerability.Fixed in 4.4.1 - Upgrade
Upgrade
composer/typo3/cms-fluidto a version that resolves this vulnerability.Fixed in 4.3.4
Event History
Frequently Asked Questions
What is the severity of CVE-2010-3672?
CVE-2010-3672 has been rated as a medium severity vulnerability due to the potential for cross-site scripting (XSS).
How do I fix CVE-2010-3672?
To remediate CVE-2010-3672, update TYPO3 CMS to version 4.3.4 or later, or version 4.4.1 or later.
Which versions of TYPO3 are affected by CVE-2010-3672?
CVE-2010-3672 affects TYPO3 versions prior to 4.3.4 and versions in the 4.4.x series before 4.4.1.
What type of vulnerability is CVE-2010-3672?
CVE-2010-3672 is a cross-site scripting (XSS) vulnerability found in the textarea view helper of TYPO3.
What components does CVE-2010-3672 impact?
CVE-2010-3672 impacts the fluid component of TYPO3 CMS.