CVE-2010-5098: TYPO3 Cross-site scripting (XSS) vulnerability in the FORM content object
Cross-site scripting (XSS) vulnerability in the FORM content object in TYPO3 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before 4.4.5, allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Other sources
TYPO3 Cross-site scripting (XSS) vulnerability in the FORM content object
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cms-frontendto a version that resolves this vulnerability.Fixed in 4.3.9 - Upgrade
Upgrade
composer/typo3/cms-frontendto a version that resolves this vulnerability.Fixed in 4.4.5 - Upgrade
Upgrade
composer/typo3/cms-frontendto a version that resolves this vulnerability.Fixed in 4.2.16
Event History
Frequently Asked Questions
What is the severity of CVE-2010-5098?
The severity of CVE-2010-5098 is considered moderate due to its potential for Cross-site Scripting attacks.
How do I fix CVE-2010-5098?
To fix CVE-2010-5098, update TYPO3 to version 4.2.16, 4.3.9, or 4.4.5 or later.
Which versions of TYPO3 are affected by CVE-2010-5098?
CVE-2010-5098 affects TYPO3 versions 4.2.x before 4.2.16, 4.3.x before 4.3.9, and 4.4.x before 4.4.5.
What type of vulnerability is CVE-2010-5098?
CVE-2010-5098 is a Cross-site Scripting (XSS) vulnerability.
Can remote users exploit CVE-2010-5098?
Yes, remote authenticated users can exploit CVE-2010-5098 to inject arbitrary web scripts or HTML.