CVE-2011-2642: XSS
An cross-site scripting (XSS) flaw was found in the way phpMyAdmin, the MySQL over WWW administration tool, displayed table names in multi tables printview. A remote attacker, able to create a particular table on the victim's server, could provide a specially-crafted URL, which once visited by valid phpMyAdmin user could lead to arbitrary JavaScript code execution.
References: [1] http://www.phpmyadmin.net/homepage/security/PMASA-2011-9.php [2] http://www.phpmyadmin.net/homepage/news.php
Upstream patches: [3] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=a0823be05aa5835f207c0838b9cca67d2d9a050a [4] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=4bd27166c314faa37cada91533b86377f4d4d214 [5] http://phpmyadmin.git.sourceforge.net/git/gitweb.cgi?p=phpmyadmin/phpmyadmin;a=commitdiff;h=8ac8328229ae7493d6060b6272578d85879c698d (against the 3.3 branch)
Other sources
Multiple cross-site scripting (XSS) vulnerabilities in the table Print view implementation in tblprintview.php in phpMyAdmin before 3.3.10.3 and 3.4.x before 3.4.3.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted table name.
— MITRE
Affected Software
Remediation
Patch Available
Event History
Frequently Asked Questions
What is the severity of CVE-2011-2642?
CVE-2011-2642 is classified as a medium severity vulnerability due to its potential to allow cross-site scripting (XSS) attacks.
How can I fix CVE-2011-2642?
To mitigate CVE-2011-2642, upgrade phpMyAdmin to version 3.3.10.2 or later, or apply any official patches released by phpMyAdmin.
Which versions of phpMyAdmin are affected by CVE-2011-2642?
CVE-2011-2642 affects phpMyAdmin versions 2.11.0 to 3.3.10.1.
What kind of attack can be executed using CVE-2011-2642?
Exploiting CVE-2011-2642 allows a remote attacker to perform XSS attacks by crafting malicious URLs associated with table names.
Is CVE-2011-2642 still relevant today?
While CVE-2011-2642 is an older vulnerability, it remains relevant for installations of affected versions of phpMyAdmin still in use.