CVE-2011-4297: Moodle does not properly restrict comment capabilities
comment/lib.php in Moodle 2.0.x before 2.0.4 and 2.1.x before 2.1.1 does not properly restrict comment capabilities, which allows remote attackers to post a comment by leveraging the guest role and operating on a front-page activity.
Other sources
Moodle does not properly restrict comment capabilities
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.1.1 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.0.4 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.0.4 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.1.1
Event History
Frequently Asked Questions
What is the severity of CVE-2011-4297?
CVE-2011-4297 is classified as a vulnerability that can lead to unauthorized comment posting due to insufficient restrictions.
How do I fix CVE-2011-4297?
To fix CVE-2011-4297, upgrade Moodle to version 2.0.4 or 2.1.1 or later.
What versions of Moodle are affected by CVE-2011-4297?
CVE-2011-4297 affects Moodle versions 2.0.0 through 2.0.3 and 2.1.0.
Can remote attackers exploit CVE-2011-4297?
Yes, remote attackers can exploit CVE-2011-4297 to post comments by using the guest role.
What component of Moodle is vulnerable in CVE-2011-4297?
CVE-2011-4297 affects the comment/lib.php component in Moodle.