CVE-2011-4299: Moodle vulnerable to Cross-Site Scripting
Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.
Other sources
Moodle vulnerable to Cross-Site Scripting
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.1.2 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.0.5
Event History
Frequently Asked Questions
What is the severity of CVE-2011-4299?
CVE-2011-4299 has a moderate severity level due to its potential for cross-site scripting attacks.
How do I fix CVE-2011-4299?
The vulnerability CVE-2011-4299 can be mitigated by upgrading to Moodle version 2.0.5 or 2.1.2 or later.
What versions of Moodle are affected by CVE-2011-4299?
CVE-2011-4299 affects Moodle versions 2.0.0 through 2.0.4 and 2.1.0 through 2.1.1.
What type of attack can be executed using CVE-2011-4299?
CVE-2011-4299 allows remote authenticated users to perform cross-site scripting (XSS) attacks through wiki comments.
Who is vulnerable to CVE-2011-4299?
Remote authenticated users of affected Moodle versions are vulnerable to exploitation of CVE-2011-4299.