CVE-2011-4628: Typo3 Authentication Bypass

Published Nov 6, 2019
·
Updated

Typo3 Authentication Bypass

Other sources

TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to bypass authentication mechanisms in the backend through a crafted request.

— GitHub

Affected Software

10 affected componentsFixes available
composer/typo3/cms>=4.5.0<4.5.4
4.5.4
composer/typo3/cms>=4.4.0<4.4.9
4.4.9
composer/typo3/cms<4.3.12
4.3.12
Typo3 TYPO3>=4.5.0<4.5.4
Typo3 TYPO3>=4.3.0<4.3.12
Typo3 TYPO3>=4.4.0<4.4.9
composer/typo3/cms>=4.5.0, <4.5.4
4.5.4
composer/typo3/cms>=4.4.0, <4.4.9
4.4.9
composer/typo3/cms<4.3.12
4.3.12
debian/typo3-src

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.5.4
  2. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.4.9
  3. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.3.12

Event History

Nov 6, 2019
CVE Published
via MITRE·04:22 PM
Data Sourced
via MITRE·04:22 PM
DescriptionWeakness
Data Sourced
via NVD·05:15 PM
DescriptionSeverityWeaknessAffected Software
Apr 22, 2022
Advisory Published
via GitHub·12:24 AM
Data Sourced
via GitHub·12:24 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:24 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2011-4628?

CVE-2011-4628 is classified as a medium severity vulnerability due to its potential for unauthorized access through authentication bypass.

2

How do I fix CVE-2011-4628?

To fix CVE-2011-4628, upgrade TYPO3 to version 4.3.12, 4.4.9, or 4.5.4 or later.

3

Who is affected by CVE-2011-4628?

CVE-2011-4628 affects users of TYPO3 versions before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4.

4

What type of vulnerability is CVE-2011-4628?

CVE-2011-4628 is an authentication bypass vulnerability that allows remote attackers to exploit backend security mechanisms.

5

Can CVE-2011-4628 be exploited remotely?

Yes, CVE-2011-4628 can be exploited remotely by sending a crafted request to the TYPO3 backend.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203