CVE-2012-1159: Moodle included private user files in course backups

Published Nov 14, 2019
·
Updated

Moodle before 2.2.2 is vulnerable to information disclosure because course backups were including users' private files.

Other sources

Moodle before 2.2.2: Overview report allows users to see hidden courses

— Debian

Moodle included private user files in course backups

— Packagist

Affected Software

13 affected componentsFixes available
composer/moodle/moodle<1.9.17
1.9.17
composer/moodle/moodle>=2.0<=2.0.7
2.0.8
composer/moodle/moodle>=2.1<=2.1.4
2.1.5
composer/moodle/moodle>=2.2<=2.2.1
2.2.2
debian/moodle
Moodle Moodle<2.2.2
Fedoraproject Fedora=15
Fedoraproject Fedora=16
Fedoraproject Fedora=17
composer/moodle/moodle<1.9.17
1.9.17
composer/moodle/moodle>=2.0, <=2.0.7
composer/moodle/moodle>=2.1, <=2.1.4
composer/moodle/moodle>=2.2, <=2.2.1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 1.9.17
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.0.8
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.1.5
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.2.2

Event History

Nov 14, 2019
CVE Published
via MITRE·04:16 PM
Data Sourced
via MITRE·04:16 PM
DescriptionWeakness
Data Sourced
via NVD·05:15 PM
RemedyDescriptionSeverityWeaknessAffected Software
Apr 23, 2022
Advisory Published
12:40 AM
Data Sourced
via GitHub·12:40 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:40 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2012-1159?

CVE-2012-1159 has been classified as a medium severity vulnerability due to its potential for information disclosure.

2

How do I fix CVE-2012-1159?

To fix CVE-2012-1159, upgrade Moodle to at least version 2.2.2 or apply any relevant patches.

3

What versions of Moodle are affected by CVE-2012-1159?

CVE-2012-1159 affects Moodle versions prior to 2.2.2, including 1.9.17 and versions between 2.0 and 2.2.1.

4

What type of vulnerability is CVE-2012-1159?

CVE-2012-1159 is an information disclosure vulnerability that allows exposure of users' private files during course backups.

5

Which systems are vulnerable to CVE-2012-1159?

Systems running vulnerable versions of Moodle, including versions prior to 2.2.2, are at risk from CVE-2012-1159.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203