CVE-2012-2112: Typo3 Exception Handler XSS
Cross-site scripting (XSS) vulnerability in the Exception Handler in TYPO3 4.4.x before 4.4.15, 4.5.x before 4.5.15, 4.6.x before 4.6.8, and 4.7 allows remote attackers to inject arbitrary web script or HTML via exception messages.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.6.8 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.5.15 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.4.15
Event History
Frequently Asked Questions
What is the severity of CVE-2012-2112?
CVE-2012-2112 has a medium severity level due to its potential for remote cross-site scripting attacks.
How do I fix CVE-2012-2112?
To fix CVE-2012-2112, upgrade TYPO3 to version 4.4.15, 4.5.15, 4.6.8, or later.
Which versions are affected by CVE-2012-2112?
CVE-2012-2112 affects TYPO3 versions 4.4.x before 4.4.15, 4.5.x before 4.5.15, 4.6.x before 4.6.8, and 4.7.
What type of vulnerability is CVE-2012-2112?
CVE-2012-2112 is a cross-site scripting (XSS) vulnerability.
What can attackers do with CVE-2012-2112?
Attackers can inject arbitrary web scripts or HTML into the application via exception messages.