CVE-2012-3530: Typo3 API XSS Vulnerability

Published Sep 5, 2012
·
Updated

Incomplete blacklist vulnerability in the t3libdiv::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.

Other sources

Incomplete blacklist vulnerability in the t3libdiv::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.

— NVD

Affected Software

44 affected componentsFixes available
composer/typo3/cms>=4.7<4.7.4
4.7.4
composer/typo3/cms>=4.6<4.6.12
4.6.12
composer/typo3/cms>=4.5<4.5.19
4.5.19
Typo3 TYPO3=4.5
Typo3 TYPO3=4.5.0
Typo3 TYPO3=4.5.1
Typo3 TYPO3=4.5.2
Typo3 TYPO3=4.5.3
Typo3 TYPO3=4.5.4
Typo3 TYPO3=4.5.5
Typo3 TYPO3=4.5.6
Typo3 TYPO3=4.5.7
Typo3 TYPO3=4.5.8
Typo3 TYPO3=4.5.9
Typo3 TYPO3=4.5.10
Typo3 TYPO3=4.5.11
Typo3 TYPO3=4.5.12
Typo3 TYPO3=4.5.13
Typo3 TYPO3=4.5.14
Typo3 TYPO3=4.5.15
Typo3 TYPO3=4.5.16
Typo3 TYPO3=4.5.17
Typo3 TYPO3=4.5.18
Typo3 TYPO3=4.6
Typo3 TYPO3=4.6.0
Typo3 TYPO3=4.6.1
Typo3 TYPO3=4.6.2
Typo3 TYPO3=4.6.3
Typo3 TYPO3=4.6.4
Typo3 TYPO3=4.6.5
Typo3 TYPO3=4.6.6
Typo3 TYPO3=4.6.7
Typo3 TYPO3=4.6.8
Typo3 TYPO3=4.6.9
Typo3 TYPO3=4.6.10
Typo3 TYPO3=4.6.11
Typo3 TYPO3=4.7
Typo3 TYPO3=4.7.0
Typo3 TYPO3=4.7.1
Typo3 TYPO3=4.7.2
Typo3 TYPO3=4.7.3
composer/typo3/cms>=4.7, <4.7.4
4.7.4
composer/typo3/cms>=4.6, <4.6.12
4.6.12
composer/typo3/cms>=4.5, <4.5.19
4.5.19

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.7.4
  2. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.6.12
  3. Upgrade

    Upgrade composer/typo3/cms to a version that resolves this vulnerability.

    Fixed in 4.5.19

Event History

Sep 5, 2012
CVE Published
via MITRE·11:00 PM
Data Sourced
via MITRE·11:00 PM
Description
Data Sourced
via NVD·11:55 PM
DescriptionSeverityAffected Software
May 17, 2022
Advisory Published
via GitHub·01:43 AM
Data Sourced
via Packagist·01:43 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2012-3530?

CVE-2012-3530 has a medium severity level, allowing for cross-site scripting attacks.

2

How do I fix CVE-2012-3530?

To fix CVE-2012-3530, upgrade to TYPO3 versions 4.5.19, 4.6.12, or 4.7.4 or later.

3

What software is affected by CVE-2012-3530?

CVE-2012-3530 affects TYPO3 versions prior to 4.5.19, 4.6.12, and 4.7.4.

4

Can CVE-2012-3530 be exploited remotely?

Yes, CVE-2012-3530 can be exploited remotely by attackers through JavaScript events.

5

Is there a patch available for CVE-2012-3530?

Yes, patches are included in TYPO3 versions 4.5.19, 4.6.12, and 4.7.4.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203