CVE-2012-3531: Typo3 Install Tool XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the Install Tool in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.7.4 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.6.12 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.5.19 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.5.19 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.6.12 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.7.4
Event History
Frequently Asked Questions
What is the severity of CVE-2012-3531?
CVE-2012-3531 is classified as a medium-severity vulnerability due to its potential for cross-site scripting attacks.
How do I fix CVE-2012-3531?
To mitigate CVE-2012-3531, you should upgrade to TYPO3 version 4.5.19, 4.6.12, or 4.7.4 or later.
What applications are affected by CVE-2012-3531?
CVE-2012-3531 affects TYPO3 versions 4.5.x before 4.5.19, 4.6.x before 4.6.12, and 4.7.x before 4.7.4.
What type of vulnerability is CVE-2012-3531?
CVE-2012-3531 is a cross-site scripting (XSS) vulnerability that allows remote attackers to inject arbitrary web scripts or HTML.
What versions of TYPO3 should I avoid due to CVE-2012-3531?
You should avoid using TYPO3 versions 4.5.x prior to 4.5.19, 4.6.x prior to 4.6.12, and 4.7.x prior to 4.7.4 due to CVE-2012-3531.