CVE-2012-6145: Typo3 Backend History Module Vulnerable to XSS
Cross-site scripting (XSS) vulnerability in the Backend History module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
Other sources
Typo3 Backend History Module Vulnerable to XSS
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.7.6 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.6.14 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.5.21
Event History
Frequently Asked Questions
What is the severity of CVE-2012-6145?
CVE-2012-6145 has a medium severity rating due to its potential to allow XSS attacks that can compromise authenticated backend users.
How do I fix CVE-2012-6145?
To fix CVE-2012-6145, upgrade TYPO3 to versions 4.5.21, 4.6.14, or 4.7.6 or later.
What type of vulnerability is CVE-2012-6145?
CVE-2012-6145 is a cross-site scripting (XSS) vulnerability that affects TYPO3 backend systems.
Who is affected by CVE-2012-6145?
CVE-2012-6145 affects remote authenticated backend users of TYPO3 versions prior to the fixed versions.
What can an attacker do with CVE-2012-6145?
An attacker exploiting CVE-2012-6145 can inject arbitrary web scripts or HTML into the TYPO3 backend.