CVE-2012-6146: Typo3 Backend History Module Vulnerable to XSS
The Backend History Module in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 does not properly restrict access, which allows remote authenticated editors to read the history of arbitrary records via a crafted URL.
Other sources
Typo3 Backend History Module Vulnerable to XSS
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.7.6 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.6.14 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.5.21 - Upgrade
Upgrade
TYPO3to a version that resolves this vulnerability.Fixed in 4.5.21
Event History
Frequently Asked Questions
What is the severity of CVE-2012-6146?
CVE-2012-6146 has a low to medium severity level due to improper access restrictions.
How do I fix CVE-2012-6146?
To fix CVE-2012-6146, upgrade your TYPO3 installation to at least version 4.5.21, 4.6.14, or 4.7.6.
What versions of TYPO3 are affected by CVE-2012-6146?
CVE-2012-6146 affects TYPO3 versions prior to 4.5.21, 4.6.14, and 4.7.6.
Can remote authenticated users exploit CVE-2012-6146?
Yes, remote authenticated users can exploit CVE-2012-6146 to access the history of arbitrary records through crafted URLs.
Is there a workaround for CVE-2012-6146?
There is no official workaround for CVE-2012-6146; the recommended action is to update to a secure version.