CVE-2012-6147: Typo3 Backend API XSS Vulnerability
Cross-site scripting (XSS) vulnerability in the tree render API (TCA-Tree) in the Backend API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.7.6 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.6.14 - Upgrade
Upgrade
composer/typo3/cmsto a version that resolves this vulnerability.Fixed in 4.5.21
Event History
Frequently Asked Questions
What is the severity of CVE-2012-6147?
CVE-2012-6147 is classified as a medium severity cross-site scripting (XSS) vulnerability.
How do I fix CVE-2012-6147?
To fix CVE-2012-6147, upgrade TYPO3 to version 4.5.21, 4.6.14, or 4.7.6 or later.
Which versions of TYPO3 are affected by CVE-2012-6147?
Versions of TYPO3 before 4.5.21, 4.6.14, and 4.7.6 are affected by CVE-2012-6147.
Can CVE-2012-6147 be exploited by unauthenticated users?
No, CVE-2012-6147 requires remote authenticated backend users to exploit the vulnerability.
What type of vulnerability is CVE-2012-6147?
CVE-2012-6147 is a cross-site scripting (XSS) vulnerability.