CVE-2013-1348: Ability to enable/disable PHP parsing in Yaml::parse()

Published Jan 15, 2013
·
Updated

Ability to enable/disable PHP parsing in Yaml::parse()

Other sources

The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.

— GitHub

The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.

Affected Software

28 affected componentsFixes available
composer/symfony/symfony>=2.0.0, <2.0.22
composer/symfony/yaml>=2.0.0, <2.0.22
composer/symfony/yaml>=2.0.0<2.0.22
2.0.22
composer/symfony/symfony>=2.0.0<2.0.22
2.0.22
SensioLabs Symfony=2.0.0
SensioLabs Symfony=2.0.1
SensioLabs Symfony=2.0.2
SensioLabs Symfony=2.0.3
SensioLabs Symfony=2.0.4
SensioLabs Symfony=2.0.5
SensioLabs Symfony=2.0.6
SensioLabs Symfony=2.0.7
SensioLabs Symfony=2.0.8
SensioLabs Symfony=2.0.9
SensioLabs Symfony=2.0.10
SensioLabs Symfony=2.0.11
SensioLabs Symfony=2.0.12
SensioLabs Symfony=2.0.13
SensioLabs Symfony=2.0.14
SensioLabs Symfony=2.0.15
SensioLabs Symfony=2.0.16
SensioLabs Symfony=2.0.17
SensioLabs Symfony=2.0.18
SensioLabs Symfony=2.0.19
SensioLabs Symfony=2.0.20
SensioLabs Symfony=2.0.21
composer/symfony/symfony>=2.0.0, <2.0.22
2.0.22
composer/symfony/yaml>=2.0.0, <2.0.22
2.0.22

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/symfony/yaml to a version that resolves this vulnerability.

    Fixed in 2.0.22
  2. Upgrade

    Upgrade composer/symfony/symfony to a version that resolves this vulnerability.

    Fixed in 2.0.22
  3. Upgrade

    Upgrade Symfony to a version that resolves this vulnerability.

    Fixed in 2.0.22

Event History

Jan 15, 2013
Advisory Published
09:16 PM
Data Sourced
via Packagist·09:16 PM
DescriptionSeverityAffected Software
Jun 2, 2014
CVE Published
via MITRE·03:00 PM
Data Sourced
via MITRE·03:00 PM
Description
Data Sourced
via NVD·03:55 PM
DescriptionSeverityWeaknessAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2013-1348?

CVE-2013-1348 is considered a critical vulnerability due to its potential to allow remote code execution.

2

How do I fix CVE-2013-1348?

To fix CVE-2013-1348, you should upgrade your Symfony version to 2.0.22 or later.

3

Which Symfony versions are affected by CVE-2013-1348?

CVE-2013-1348 affects Symfony versions from 2.0.0 up to 2.0.21.

4

Can CVE-2013-1348 be exploited remotely?

Yes, CVE-2013-1348 can be exploited remotely by attackers to execute arbitrary PHP code.

5

Is CVE-2013-1348 related to any other vulnerabilities?

CVE-2013-1348 is related to CVE-2013-1397 but addresses a different issue regarding PHP code execution.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203