CVE-2013-1830: Moodle does not enforce the forceloginforprofiles setting

Published Mar 25, 2013
·
Updated

user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.

Other sources

Moodle does not enforce the forceloginforprofiles setting

— Packagist

user/view.php in Moodle through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 does not enforce the forceloginforprofiles setting, which allows remote attackers to obtain sensitive course-profile information by leveraging the guest role, as demonstrated by a Google search.

— MITRE

Affected Software

111 affected componentsFixes available
composer/moodle/moodle>=2.4.0<2.4.2
2.4.2
composer/moodle/moodle>=2.3.0<2.3.5
2.3.5
composer/moodle/moodle>=2.2.0<2.2.8
2.2.8
composer/moodle/moodle<=2.1.10
Fedoraproject Fedora=17
Fedoraproject Fedora=18
Moodle Moodle=2.2.0
Moodle Moodle=2.2.1
Moodle Moodle=2.2.2
Moodle Moodle=2.2.3
Moodle Moodle=2.2.4
Moodle Moodle=2.2.5
Moodle Moodle=2.2.6
Moodle Moodle=2.2.7
Moodle Moodle=2.4.0
Moodle Moodle=2.4.1
Moodle Moodle=2.3.0
Moodle Moodle=2.3.1
Moodle Moodle=2.3.2
Moodle Moodle=2.3.3
Moodle Moodle=2.3.4
Moodle Moodle=1.1.1
Moodle Moodle=1.2.0
Moodle Moodle=1.2.1
Moodle Moodle=1.3.0
Moodle Moodle=1.3.1
Moodle Moodle=1.3.2
Moodle Moodle=1.3.3
Moodle Moodle=1.3.4
Moodle Moodle=1.4.1
Moodle Moodle=1.4.2
Moodle Moodle=1.4.3
Moodle Moodle=1.4.4
Moodle Moodle=1.4.5
Moodle Moodle=1.5
Moodle Moodle=1.5.0-beta
Moodle Moodle=1.5.1
Moodle Moodle=1.5.2
Moodle Moodle=1.5.3
Moodle Moodle=1.6.0
Moodle Moodle=1.6.1
Moodle Moodle=1.6.2
Moodle Moodle=1.6.3
Moodle Moodle=1.6.4
Moodle Moodle=1.6.5
Moodle Moodle=1.6.6
Moodle Moodle=1.6.7
Moodle Moodle=1.6.8
Moodle Moodle=1.7.1
Moodle Moodle=1.7.2
Moodle Moodle=1.7.3
Moodle Moodle=1.7.4
Moodle Moodle=1.7.5
Moodle Moodle=1.7.6
Moodle Moodle=1.8.1
Moodle Moodle=1.8.2
Moodle Moodle=1.8.3
Moodle Moodle=1.8.4
Moodle Moodle=1.8.5
Moodle Moodle=1.8.6
Moodle Moodle=1.8.7
Moodle Moodle=1.8.8
Moodle Moodle=1.8.9
Moodle Moodle=1.8.10
Moodle Moodle=1.8.11
Moodle Moodle=1.8.12
Moodle Moodle=1.8.13
Moodle Moodle=1.8.14
Moodle Moodle=1.9.1
Moodle Moodle=1.9.2
Moodle Moodle=1.9.3
Moodle Moodle=1.9.4
Moodle Moodle=1.9.5
Moodle Moodle=1.9.6
Moodle Moodle=1.9.7
Moodle Moodle=1.9.8
Moodle Moodle=1.9.9
Moodle Moodle=1.9.10
Moodle Moodle=1.9.11
Moodle Moodle=1.9.12
Moodle Moodle=1.9.13
Moodle Moodle=1.9.14
Moodle Moodle=1.9.15
Moodle Moodle=1.9.16
Moodle Moodle=1.9.17
Moodle Moodle=1.9.18
Moodle Moodle=2.0.0
Moodle Moodle=2.0.1
Moodle Moodle=2.0.2
Moodle Moodle=2.0.3
Moodle Moodle=2.0.4
Moodle Moodle=2.0.5
Moodle Moodle=2.0.6
Moodle Moodle=2.0.7
Moodle Moodle=2.0.8
Moodle Moodle=2.0.9
Moodle Moodle=2.1.0
Moodle Moodle=2.1.1
Moodle Moodle=2.1.2
Moodle Moodle=2.1.3
Moodle Moodle=2.1.4
Moodle Moodle=2.1.5
Moodle Moodle=2.1.6
Moodle Moodle=2.1.7
Moodle Moodle=2.1.8
Moodle Moodle=2.1.9
Moodle Moodle=2.1.10
composer/moodle/moodle>=2.4.0, <2.4.2
2.4.2
composer/moodle/moodle>=2.3.0, <2.3.5
2.3.5
composer/moodle/moodle>=2.2.0, <2.2.8
2.2.8
composer/moodle/moodle<=2.1.10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.3.5
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.2.8

Event History

Mar 25, 2013
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description
Data Sourced
via NVD·09:55 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2013-1830?

CVE-2013-1830 has been classified with a high severity due to the exposure of sensitive course-profile information.

2

How do I fix CVE-2013-1830?

To fix CVE-2013-1830, update your Moodle installation to version 2.4.2 or later, or 2.3.5 or later, or 2.2.8 or later.

3

Which versions of Moodle are affected by CVE-2013-1830?

CVE-2013-1830 affects Moodle versions 2.1.10 and prior, as well as 2.2.x versions before 2.2.8, 2.3.x versions before 2.3.5, and 2.4.x versions before 2.4.2.

4

Can guest users exploit CVE-2013-1830?

Yes, CVE-2013-1830 allows remote attackers with guest roles to exploit the vulnerability and access sensitive information.

5

Was CVE-2013-1830 a result of configuration settings in Moodle?

Yes, CVE-2013-1830 was caused by the failure to enforce the 'forceloginforprofiles' setting in Moodle.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203