CVE-2013-1833: Moodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module

Published Mar 25, 2013
·
Updated

Moodle Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module

Other sources

Multiple cross-site scripting (XSS) vulnerabilities in the File Picker module in Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allow remote authenticated users to inject arbitrary web script or HTML via a crafted filename.

— GitHub

Affected Software

44 affected componentsFixes available
composer/moodle/moodle>=2.0.0<=2.1.10
composer/moodle/moodle>=2.4.0<2.4.2
2.4.2
composer/moodle/moodle>=2.3.0<2.3.5
2.3.5
composer/moodle/moodle>=2.2.0<2.2.8
2.2.8
Moodle Moodle=2.0.0
Moodle Moodle=2.0.1
Moodle Moodle=2.0.2
Moodle Moodle=2.0.3
Moodle Moodle=2.0.4
Moodle Moodle=2.0.5
Moodle Moodle=2.0.6
Moodle Moodle=2.0.7
Moodle Moodle=2.0.8
Moodle Moodle=2.0.9
Moodle Moodle=2.1.0
Moodle Moodle=2.1.1
Moodle Moodle=2.1.2
Moodle Moodle=2.1.3
Moodle Moodle=2.1.4
Moodle Moodle=2.1.5
Moodle Moodle=2.1.6
Moodle Moodle=2.1.7
Moodle Moodle=2.1.8
Moodle Moodle=2.1.9
Moodle Moodle=2.1.10
Moodle Moodle=2.2.0
Moodle Moodle=2.2.1
Moodle Moodle=2.2.2
Moodle Moodle=2.2.3
Moodle Moodle=2.2.4
Moodle Moodle=2.2.5
Moodle Moodle=2.2.6
Moodle Moodle=2.2.7
Moodle Moodle=2.3.0
Moodle Moodle=2.3.1
Moodle Moodle=2.3.2
Moodle Moodle=2.3.3
Moodle Moodle=2.3.4
Moodle Moodle=2.4.0
Moodle Moodle=2.4.1
composer/moodle/moodle>=2.0.0, <=2.1.10
composer/moodle/moodle>=2.4.0, <2.4.2
2.4.2
composer/moodle/moodle>=2.3.0, <2.3.5
2.3.5
composer/moodle/moodle>=2.2.0, <2.2.8
2.2.8

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.3.5
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.2.8

Event History

Mar 25, 2013
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description
Data Sourced
via NVD·09:55 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2013-1833?

CVE-2013-1833 has a medium severity rating due to its potential for XSS attacks.

2

How do I fix CVE-2013-1833?

To fix CVE-2013-1833, upgrade to Moodle versions 2.2.8, 2.3.5, or 2.4.2 or later.

3

Who is affected by CVE-2013-1833?

CVE-2013-1833 affects Moodle versions ranging from 2.0.0 through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2.

4

What type of vulnerability is CVE-2013-1833?

CVE-2013-1833 is classified as a cross-site scripting (XSS) vulnerability.

5

Can CVE-2013-1833 be exploited by unauthenticated users?

No, CVE-2013-1833 can only be exploited by remote authenticated users.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203