CVE-2013-1834: Moodle allows remote authenticated users to reassign notes
Moodle allows remote authenticated users to reassign notes
Other sources
notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated users to reassign notes via a modified (1) userid or (2) courseid field.
— GitHub
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.4.2 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.3.5 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.2.8
Event History
Frequently Asked Questions
What is the severity of CVE-2013-1834?
CVE-2013-1834 is classified as a moderate severity vulnerability.
How do I fix CVE-2013-1834?
To fix CVE-2013-1834, upgrade to Moodle version 2.4.2, 2.3.5, or 2.2.8 or later.
Who is affected by CVE-2013-1834?
CVE-2013-1834 affects remote authenticated users on Moodle versions 1.9.x, 2.x, and specific earlier releases.
What type of vulnerability is CVE-2013-1834?
CVE-2013-1834 is an authorization vulnerability that allows reassignment of notes.
Is there a workaround for CVE-2013-1834 if I can't upgrade?
There is no official workaround for CVE-2013-1834; upgrading to a fixed version is recommended.