CVE-2013-1835: Moodle's login_as feature leaks information from external repositories

Published Mar 25, 2013
·
Updated

Moodle 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated administrators to obtain sensitive information from the external repositories of arbitrary users by leveraging the loginas feature.

Other sources

Moodle's loginas feature leaks information from external repositories

— Packagist

Affected Software

42 affected componentsFixes available
composer/moodle/moodle>=2.4.0<2.4.2
2.4.2
composer/moodle/moodle>=2.3.0<2.3.5
2.3.5
composer/moodle/moodle>=2.0.0<2.2.8
2.2.8
Moodle Moodle=2.0.0
Moodle Moodle=2.0.1
Moodle Moodle=2.0.2
Moodle Moodle=2.0.3
Moodle Moodle=2.0.4
Moodle Moodle=2.0.5
Moodle Moodle=2.0.6
Moodle Moodle=2.0.7
Moodle Moodle=2.0.8
Moodle Moodle=2.0.9
Moodle Moodle=2.1.0
Moodle Moodle=2.1.1
Moodle Moodle=2.1.2
Moodle Moodle=2.1.3
Moodle Moodle=2.1.4
Moodle Moodle=2.1.5
Moodle Moodle=2.1.6
Moodle Moodle=2.1.7
Moodle Moodle=2.1.8
Moodle Moodle=2.1.9
Moodle Moodle=2.1.10
Moodle Moodle=2.2.0
Moodle Moodle=2.2.1
Moodle Moodle=2.2.2
Moodle Moodle=2.2.3
Moodle Moodle=2.2.4
Moodle Moodle=2.2.5
Moodle Moodle=2.2.6
Moodle Moodle=2.2.7
Moodle Moodle=2.3.0
Moodle Moodle=2.3.1
Moodle Moodle=2.3.2
Moodle Moodle=2.3.3
Moodle Moodle=2.3.4
Moodle Moodle=2.4.0
Moodle Moodle=2.4.1
composer/moodle/moodle>=2.4.0, <2.4.2
2.4.2
composer/moodle/moodle>=2.3.0, <2.3.5
2.3.5
composer/moodle/moodle>=2.0.0, <2.2.8
2.2.8

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.4.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.3.5
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.2.8

Event History

Mar 25, 2013
CVE Published
via MITRE·09:00 PM
Data Sourced
via MITRE·09:00 PM
Description
Data Sourced
via NVD·09:55 PM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via GitHub·01:12 AM
DescriptionWeaknessAffected Software
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2013-1835?

CVE-2013-1835 is classified as a moderate severity vulnerability due to its potential for unauthorized access to sensitive user information.

2

How do I fix CVE-2013-1835?

To fix CVE-2013-1835, you should upgrade to Moodle versions 2.4.2, 2.3.5, or 2.2.8 or later.

3

Who is affected by CVE-2013-1835?

CVE-2013-1835 affects Moodle versions 2.x up to 2.4.1, specifically allowing authenticated administrators to access external repositories.

4

What are the implications of CVE-2013-1835?

The implications of CVE-2013-1835 include potential exposure of sensitive information from external repositories of users.

5

Is there a specific workaround for CVE-2013-1835?

There is no specific workaround for CVE-2013-1835; the recommended solution is to update to the secured versions.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203