CVE-2013-2081: Moodle does not consider "don't send" attributes during hub registration

Published May 25, 2013
·
Updated

Moodle does not consider "don't send" attributes during hub registration

Other sources

Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not consider "don't send" attributes during hub registration, which allows remote hubs to obtain sensitive site information by reading form data.

— GitHub

Affected Software

38 affected componentsFixes available
composer/moodle/moodle>=2.4.0<2.4.4
2.4.4
composer/moodle/moodle>=2.3.0<2.3.7
2.3.7
composer/moodle/moodle<2.2.10
2.2.10
Moodle Moodle=2.1.0
Moodle Moodle=2.1.1
Moodle Moodle=2.1.2
Moodle Moodle=2.1.3
Moodle Moodle=2.1.4
Moodle Moodle=2.1.5
Moodle Moodle=2.1.6
Moodle Moodle=2.1.7
Moodle Moodle=2.1.8
Moodle Moodle=2.1.9
Moodle Moodle=2.1.10
Moodle Moodle=2.2.0
Moodle Moodle=2.2.1
Moodle Moodle=2.2.2
Moodle Moodle=2.2.3
Moodle Moodle=2.2.4
Moodle Moodle=2.2.5
Moodle Moodle=2.2.6
Moodle Moodle=2.2.7
Moodle Moodle=2.2.8
Moodle Moodle=2.2.9
Moodle Moodle=2.3.0
Moodle Moodle=2.3.1
Moodle Moodle=2.3.2
Moodle Moodle=2.3.3
Moodle Moodle=2.3.4
Moodle Moodle=2.3.5
Moodle Moodle=2.3.6
Moodle Moodle=2.4.0
Moodle Moodle=2.4.1
Moodle Moodle=2.4.2
Moodle Moodle=2.4.3
composer/moodle/moodle>=2.4.0, <2.4.4
2.4.4
composer/moodle/moodle>=2.3.0, <2.3.7
2.3.7
composer/moodle/moodle<2.2.10
2.2.10

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.4.4
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.3.7
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.2.10

Event History

May 25, 2013
CVE Published
via MITRE·01:00 AM
Data Sourced
via MITRE·01:00 AM
Description
Data Sourced
via NVD·03:18 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2013-2081?

CVE-2013-2081 is classified as a medium severity vulnerability due to the potential exposure of sensitive site information.

2

How do I fix CVE-2013-2081?

To fix CVE-2013-2081, you should upgrade to Moodle version 2.4.4 or later, 2.3.7 or later, or 2.2.10 or later.

3

What systems are affected by CVE-2013-2081?

CVE-2013-2081 affects Moodle versions 2.1.0 through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4.

4

Is CVE-2013-2081 an exploit or a vulnerability?

CVE-2013-2081 is a vulnerability that allows remote hubs to access sensitive site information.

5

Can CVE-2013-2081 affect my Moodle site?

Yes, if you are using any of the affected Moodle versions, your site could be compromised by CVE-2013-2081.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203