CVE-2014-2683: Several Zend Products Vulnerable to XXE and XEE attacks
Several Zend Products Vulnerable to XXE and XEE attacks
Other sources
Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendServiceAudioScrobbler, ZendServiceNirvanix, ZendServiceSlideShare, ZendServiceTechnorati, and ZendServiceWindowsAzure before 2.0.2, ZendServiceAmazon before 2.0.3, and ZendServiceApi before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/zendframework/zendservice-apito a version that resolves this vulnerability.Fixed in 1.0.0 - Upgrade
Upgrade
composer/zendframework/zendservice-amazonto a version that resolves this vulnerability.Fixed in 2.0.3 - Upgrade
Upgrade
composer/zendframework/zendservice-windowsazureto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendservice-technoratito a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendservice-slideshareto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendservice-nirvanixto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendservice-audioscrobblerto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendrestto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendopenidto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
composer/zendframework/zendframework1to a version that resolves this vulnerability.Fixed in 1.12.4 - Upgrade
Upgrade
Zend Framework 1 (ZF1)to a version that resolves this vulnerability.Fixed in 1.12.4 - Upgrade
Upgrade
Zend Framework 2to a version that resolves this vulnerability.Fixed in 2.1.6 - Upgrade
Upgrade
Zend Framework 2 (2.2.x branch)to a version that resolves this vulnerability.Fixed in 2.2.6 - Upgrade
Upgrade
ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, ZendService_WindowsAzureto a version that resolves this vulnerability.Fixed in 2.0.2 - Upgrade
Upgrade
ZendService_Amazonto a version that resolves this vulnerability.Fixed in 2.0.3 - Upgrade
Upgrade
ZendService_Apito a version that resolves this vulnerability.Fixed in 1.0.0
Event History
Frequently Asked Questions
What is the severity of CVE-2014-2683?
CVE-2014-2683 has a medium severity rating, indicating potential risk to applications using affected versions.
How do I fix CVE-2014-2683?
To fix CVE-2014-2683, upgrade to Zend Framework 1.12.4, Zend Framework 2.1.6 or later, or apply patches as recommended by Zend.
Which versions are affected by CVE-2014-2683?
CVE-2014-2683 affects Zend Framework 1 versions before 1.12.4 and Zend Framework 2 versions before 2.1.6 and 2.2.x before 2.2.6.
What products are impacted by CVE-2014-2683?
CVE-2014-2683 impacts multiple Zend Framework products including ZendOpenId, ZendRest, and various ZendService components.
Is CVE-2014-2683 exploitable remotely?
Yes, CVE-2014-2683 can potentially be exploited remotely if vulnerable software is exposed to the internet.