CVE-2014-3542: Moodle allows remote attackers to read arbitrary files

Published Jul 29, 2014
·
Updated

mod/lti/service.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Other sources

Moodle allows remote attackers to read arbitrary files

— Packagist

Affected Software

45 affected componentsFixes available
composer/moodle/moodle=2.7.0
2.7.1
composer/moodle/moodle>=2.6.0<2.6.4
2.6.4
composer/moodle/moodle>=2.5.0<2.5.7
2.5.7
composer/moodle/moodle>=2.4.0<2.4.11
2.4.11
composer/moodle/moodle<=2.3.11
Moodle Moodle=2.7.0
Moodle Moodle=2.6.0
Moodle Moodle=2.6.1
Moodle Moodle=2.6.2
Moodle Moodle=2.6.3
Moodle Moodle<=2.3.11
Moodle Moodle=2.3.0
Moodle Moodle=2.3.1
Moodle Moodle=2.3.2
Moodle Moodle=2.3.3
Moodle Moodle=2.3.4
Moodle Moodle=2.3.5
Moodle Moodle=2.3.6
Moodle Moodle=2.3.7
Moodle Moodle=2.3.8
Moodle Moodle=2.3.9
Moodle Moodle=2.3.10
Moodle Moodle=2.4.0
Moodle Moodle=2.4.1
Moodle Moodle=2.4.2
Moodle Moodle=2.4.3
Moodle Moodle=2.4.4
Moodle Moodle=2.4.5
Moodle Moodle=2.4.6
Moodle Moodle=2.4.7
Moodle Moodle=2.4.8
Moodle Moodle=2.4.9
Moodle Moodle=2.4.10
Moodle Moodle=2.5.0
Moodle Moodle=2.5.1
Moodle Moodle=2.5.2
Moodle Moodle=2.5.3
Moodle Moodle=2.5.4
Moodle Moodle=2.5.5
Moodle Moodle=2.5.6
composer/moodle/moodle=2.7.0
composer/moodle/moodle>=2.6.0, <2.6.4
2.6.4
composer/moodle/moodle>=2.5.0, <2.5.7
2.5.7
composer/moodle/moodle>=2.4.0, <2.4.11
2.4.11
composer/moodle/moodle<=2.3.11

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.1
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.6.4
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.5.7
  4. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.4.11

Event History

Jul 29, 2014
CVE Published
via MITRE·10:00 AM
Data Sourced
via MITRE·10:00 AM
Description
Data Sourced
via NVD·11:10 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2014-3542?

CVE-2014-3542 has a medium severity rating due to its potential for unauthorized file access.

2

How do I fix CVE-2014-3542?

To fix CVE-2014-3542, upgrade Moodle to version 2.7.1 or later, or patch affected versions as recommended.

3

Which versions of Moodle are affected by CVE-2014-3542?

CVE-2014-3542 affects Moodle versions up to 2.3.11 and from 2.4.0 to 2.4.10, 2.5.0 to 2.5.6, and 2.6.0 to 2.6.3.

4

Can CVE-2014-3542 be exploited remotely?

Yes, CVE-2014-3542 can be exploited remotely by attackers to read arbitrary files on the server.

5

What type of vulnerability is CVE-2014-3542 classified as?

CVE-2014-3542 is classified as an XML External Entity (XXE) vulnerability.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203