CVE-2014-3543: Moodle Arbitrary File Read via XML External Entity vulnerability
mod/imscp/locallib.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via a package with a manifest file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue affecting IMSCP resources and the IMSCC format.
Other sources
mod/imscp/locallib.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 allows remote attackers to read arbitrary files via a package with a manifest file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue affecting IMSCP resources and the IMSCC format.
— MITRE
Moodle Arbitrary File Read via XML External Entity vulnerability
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.4.11 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.5.7 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.6.4 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.1
Event History
Frequently Asked Questions
What is the severity of CVE-2014-3543?
CVE-2014-3543 is rated as a medium severity vulnerability, allowing remote attackers to read arbitrary files.
How do I fix CVE-2014-3543?
You can fix CVE-2014-3543 by upgrading to Moodle version 2.4.11, 2.5.7, 2.6.4, or 2.7.1 or later.
Who is affected by CVE-2014-3543?
CVE-2014-3543 affects Moodle versions from 2.3.0 through 2.7.0.
What type of vulnerability is CVE-2014-3543?
CVE-2014-3543 is an XML External Entity (XXE) vulnerability.
What attack vector is associated with CVE-2014-3543?
CVE-2014-3543 allows attackers to exploit the vulnerability via a package with a manifest file that contains an XML external entity declaration.