CVE-2014-7836: Moodle multiple cross-site request forgery (CSRF) vulnerabilities

Published Nov 24, 2014
·
Updated

Moodle multiple cross-site request forgery (CSRF) vulnerabilities

Other sources

Multiple cross-site request forgery (CSRF) vulnerabilities in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allow remote attackers to hijack the authentication of arbitrary users for a (1) mod/lti/requesttool.php or (2) mod/lti/instructoredittooltype.php request.

— GitHub

Affected Software

25 affected componentsFixes available
composer/moodle/moodle>=2.7.0<2.7.3
2.7.3
composer/moodle/moodle>=2.6.0<2.6.6
2.6.6
composer/moodle/moodle<2.5.9
2.5.9
Moodle Moodle<=2.4.11
Moodle Moodle=2.5.0
Moodle Moodle=2.5.1
Moodle Moodle=2.5.2
Moodle Moodle=2.5.3
Moodle Moodle=2.5.4
Moodle Moodle=2.5.5
Moodle Moodle=2.5.6
Moodle Moodle=2.5.7
Moodle Moodle=2.5.8
Moodle Moodle=2.6.0
Moodle Moodle=2.6.1
Moodle Moodle=2.6.2
Moodle Moodle=2.6.3
Moodle Moodle=2.6.4
Moodle Moodle=2.6.5
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
composer/moodle/moodle>=2.7.0, <2.7.3
2.7.3
composer/moodle/moodle>=2.6.0, <2.6.6
2.6.6
composer/moodle/moodle<2.5.9
2.5.9

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.3
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.6.6
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.5.9

Event History

Nov 24, 2014
CVE Published
via MITRE·11:00 AM
Data Sourced
via MITRE·11:00 AM
Description
Data Sourced
via NVD·11:59 AM
RemedyDescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2014-7836?

CVE-2014-7836 is classified as a moderate severity vulnerability due to its nature of enabling cross-site request forgery attacks.

2

How do I fix CVE-2014-7836?

To fix CVE-2014-7836, upgrade Moodle to at least version 2.5.9, 2.6.6, or 2.7.3 depending on your current version.

3

What versions of Moodle are affected by CVE-2014-7836?

CVE-2014-7836 affects Moodle versions 2.4.11 and earlier, as well as 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3.

4

What type of vulnerabilities does CVE-2014-7836 represent?

CVE-2014-7836 represents multiple cross-site request forgery (CSRF) vulnerabilities.

5

Can CVE-2014-7836 allow unauthorized access to user accounts?

Yes, CVE-2014-7836 can allow remote attackers to hijack the authentication of arbitrary users.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203