CVE-2014-9605: SQL Injection
WebUpgrade in Netsweeper before 3.1.10, 4.0.x before 4.0.9, and 4.1.x before 4.1.2 allows remote attackers to bypass authentication and create a system backup tarball, restart the server, or stop the filters on the server via a ' (single quote) character in the login and password parameters to webupgrade/webupgrade.php. NOTE: this was originally reported as an SQL injection vulnerability, but this may be inaccurate.
Affected Software
Remediation
Event History
Frequently Asked Questions
What is the severity of CVE-2014-9605?
CVE-2014-9605 is classified as a high-severity vulnerability due to its potential to allow remote attackers to bypass authentication.
How do I fix CVE-2014-9605?
To fix CVE-2014-9605, upgrade to Netsweeper version 3.1.10 or later, 4.0.9 or later, or 4.1.2 or later.
What can attackers do with CVE-2014-9605?
Attackers exploiting CVE-2014-9605 can bypass authentication, create backups, restart the server, or stop filters.
Which versions of Netsweeper are affected by CVE-2014-9605?
Netsweeper versions prior to 3.1.10, 4.0.9, and 4.1.2 are affected by CVE-2014-9605.
How is CVE-2014-9605 exploited?
CVE-2014-9605 can be exploited by injecting a single quote character in the login and password parameters during authentication.