CVE-2015-0217: Moodle allows attackers to cause a denial of service

Published Jun 1, 2015
·
Updated

filter/mediaplugin/filter.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2 allows remote authenticated users to cause a denial of service (CPU consumption or partial outage) via a crafted string that is matched against an improper regular expression.

Other sources

Moodle allows attackers to cause a denial of service

— Packagist

Affected Software

28 affected componentsFixes available
composer/moodle/moodle>=2.8.0<2.8.2
2.8.2
composer/moodle/moodle>=2.7.0<2.7.4
2.7.4
composer/moodle/moodle<2.6.7
2.6.7
Moodle Moodle<=2.5.9
Moodle Moodle=2.5.0
Moodle Moodle=2.5.1
Moodle Moodle=2.5.2
Moodle Moodle=2.5.3
Moodle Moodle=2.5.4
Moodle Moodle=2.5.5
Moodle Moodle=2.5.6
Moodle Moodle=2.5.7
Moodle Moodle=2.5.8
Moodle Moodle=2.6.0
Moodle Moodle=2.6.1
Moodle Moodle=2.6.2
Moodle Moodle=2.6.3
Moodle Moodle=2.6.4
Moodle Moodle=2.6.5
Moodle Moodle=2.6.6
Moodle Moodle=2.7.0
Moodle Moodle=2.7.1
Moodle Moodle=2.7.2
Moodle Moodle=2.7.3
Moodle Moodle=2.8.0
composer/moodle/moodle>=2.8.0, <2.8.2
2.8.2
composer/moodle/moodle>=2.7.0, <2.7.4
2.7.4
composer/moodle/moodle<2.6.7
2.6.7

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.8.2
  2. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.7.4
  3. Upgrade

    Upgrade composer/moodle/moodle to a version that resolves this vulnerability.

    Fixed in 2.6.7

Event History

Jun 1, 2015
CVE Published
via MITRE·07:00 PM
Data Sourced
via MITRE·07:00 PM
Description
Data Sourced
via NVD·07:59 PM
DescriptionSeverityWeaknessAffected Software
May 13, 2022
Advisory Published
via GitHub·01:12 AM
Data Sourced
via Packagist·01:12 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-0217?

CVE-2015-0217 has a moderate severity level as it allows remote authenticated users to cause denial of service.

2

How do I fix CVE-2015-0217?

To fix CVE-2015-0217, upgrade your Moodle installation to version 2.8.2 or later, 2.7.4 or later, or 2.6.7.

3

Which versions of Moodle are affected by CVE-2015-0217?

CVE-2015-0217 affects Moodle versions 2.5.9 and earlier, 2.6.x before 2.6.7, 2.7.x before 2.7.4, and 2.8.x before 2.8.2.

4

What kind of attack does CVE-2015-0217 enable?

CVE-2015-0217 enables remote authenticated users to launch a denial of service attack through resource exhaustion.

5

Is CVE-2015-0217 related to regular expressions in Moodle?

Yes, CVE-2015-0217 is caused by improper regular expression matching in the filter/mediaplugin/filter.php file.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203