CVE-2015-0270: Potential SQL injection in PostgreSQL Zend\Db adapter
Potential SQL injection in PostgreSQL Zend\Db adapter
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/zendframework/zend-dbto a version that resolves this vulnerability.Fixed in 2.3.5 - Upgrade
Upgrade
composer/zendframework/zend-dbto a version that resolves this vulnerability.Fixed in 2.2.10 - Upgrade
Upgrade
composer/zendframework/zendframeworkto a version that resolves this vulnerability.Fixed in 2.3.5 - Upgrade
Upgrade
composer/zendframework/zendframeworkto a version that resolves this vulnerability.Fixed in 2.2.10 - Upgrade
Upgrade
composer/zendframework/zendframeworkto a version that resolves this vulnerability.Fixed in 2.0.99 - Upgrade
Upgrade
composer/zendframework/zendframeworkto a version that resolves this vulnerability.Fixed in 2.1.99 - Upgrade
Upgrade
composer/zendframework/zend-dbto a version that resolves this vulnerability.Fixed in 2.0.99 - Upgrade
Upgrade
composer/zendframework/zend-dbto a version that resolves this vulnerability.Fixed in 2.1.99
Event History
Frequently Asked Questions
What is the severity of CVE-2015-0270?
CVE-2015-0270 has a high severity rating due to its potential for SQL injection vulnerabilities.
How do I fix CVE-2015-0270?
To fix CVE-2015-0270, update your Zend Framework to version 2.2.10 or 2.3.5 or later.
Which versions of Zend Framework are affected by CVE-2015-0270?
CVE-2015-0270 affects all versions of Zend Framework before 2.2.10 and 2.3.x before 2.3.5.
What impact does CVE-2015-0270 have on PostgreSQL databases?
CVE-2015-0270 can lead to unauthorized access and manipulation of data in PostgreSQL databases due to SQL injection.
Is CVE-2015-0270 limited to specific platforms?
CVE-2015-0270 is not limited to specific platforms but primarily affects applications using the vulnerable Zend Framework.