CVE-2015-0839: High severity HP Linux Imaging and Printing vulnerability
It was reported that the hp-plugin utility, included in the hplip package, downloads a binary driver and verifies it via a key specified by the key's short ID:
Downloading plug-in: [\ ] 0% Receiving digital keys: /bin/gpg --homedir /home/test/.hplip/.gnupg --no-permission-warning --keyserver pgp.mit.edu --recv-keys 0xA59047B9
A man-in-the-middle attacker could use this flaw to generate a key with the expected short ID and trick a user into downloading a malicious binary.
Original report:
http://seclists.org/oss-sec/2015/q2/581
Other sources
The hp-plugin utility in HP Linux Imaging and Printing (HPLIP) makes it easier for man-in-the-middle attackers to execute arbitrary code by leveraging use of a short GPG key id from a keyserver to verify print plugin downloads.
— MITRE
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
debian/hplipto a version that resolves this vulnerability.Fixed in 3.15.11+repack0-1 - Upgrade
Upgrade
debian/hplipto a version that resolves this vulnerability.Fixed in 3.22.10+dfsg0-2Fixed in 3.22.10+dfsg0-2+deb12u1Fixed in 3.22.10+dfsg0-8.1+deb13u1Fixed in 3.26.4+dfsg0-4
Event History
Frequently Asked Questions
What is the severity of CVE-2015-0839?
CVE-2015-0839 is classified as a medium severity vulnerability.
What software is affected by CVE-2015-0839?
CVE-2015-0839 affects the HP Linux Imaging and Printing (hplip) package version up to 3.17.7.
How do I fix CVE-2015-0839?
To fix CVE-2015-0839, update the hplip package to a version later than 3.17.7.
What type of vulnerability is CVE-2015-0839?
CVE-2015-0839 is a vulnerability that involves improper validation of digital signatures used for binary driver downloads.
Does CVE-2015-0839 allow for arbitrary code execution?
Yes, CVE-2015-0839 can potentially allow an attacker to execute arbitrary code if exploited.