CVE-2015-1561: Centreon Command Injection

Published Jul 14, 2015
·
Updated

Centreon Command Injection

Other sources

The escapecommand function in include/Administration/corePerformance/getStats.php in Centreon (formerly Merethis Centreon) 2.5.4 and earlier (offending file deleted in Centreon 19.10.0) uses an incorrect regular expression, which allows remote authenticated users to execute arbitrary commands via shell metacharacters in the nsid parameter.

The escapecommand function in include/Administration/corePerformance/getStats.php in Centreon (formerly Merethis Centreon) 2.5.4 and earlier (fixed in Centreon 19.10.0) uses an incorrect regular expression, which allows remote authenticated users to execute arbitrary commands via shell metacharacters in the nsid parameter.

— MITRE

Affected Software

3 affected componentsFixes available
composer/centreon/centreon<2.8.28
2.8.28
Centreon Centreon<=2.5.4
composer/centreon/centreon<2.8.28
2.8.28

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade composer/centreon/centreon to a version that resolves this vulnerability.

    Fixed in 2.8.28
  2. Upgrade

    Upgrade Centreon to a version that resolves this vulnerability.

    Fixed in 19.10.0

Event History

Jul 14, 2015
CVE Published
via MITRE·04:00 PM
Data Sourced
via MITRE·04:00 PM
Description
Data Sourced
via NVD·04:59 PM
DescriptionSeverityWeaknessAffected Software
May 14, 2022
Advisory Published
12:55 AM
Data Sourced
via GitHub·12:55 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via Packagist·12:55 AM
DescriptionSeverityAffected Software

Frequently Asked Questions

1

What is the severity of CVE-2015-1561?

CVE-2015-1561 has a high severity rating due to its potential to allow unauthorized command execution by remote authenticated users.

2

How do I fix CVE-2015-1561?

To fix CVE-2015-1561, upgrade your Centreon software to version 2.8.28 or later.

3

What versions of Centreon are affected by CVE-2015-1561?

Centreon versions 2.5.4 and earlier are affected by CVE-2015-1561.

4

What type of vulnerability is CVE-2015-1561?

CVE-2015-1561 is a remote code execution vulnerability due to an incorrect regular expression in the `escape_command` function.

5

Is CVE-2015-1561 still exploitable in later versions of Centreon?

No, CVE-2015-1561 is no longer exploitable in Centreon version 19.10.0 and later, as the offending file was deleted.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203