CVE-2015-2267: Moodle allows attackers to extract archives to arbitrary directories
mdeploy.php in Moodle through 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4 allows remote authenticated users to bypass intended access restrictions and extract archives to arbitrary directories via a crafted dataroot value.
Other sources
Moodle allows attackers to extract archives to arbitrary directories
— Packagist
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.8.4 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.7.6 - Upgrade
Upgrade
composer/moodle/moodleto a version that resolves this vulnerability.Fixed in 2.6.9 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.6.9 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.7.6 - Upgrade
Upgrade
Moodleto a version that resolves this vulnerability.Fixed in 2.8.4
Event History
Frequently Asked Questions
What is the severity of CVE-2015-2267?
CVE-2015-2267 is classified as a high severity vulnerability allowing unauthorized access to the file system.
How do I fix CVE-2015-2267?
To fix CVE-2015-2267, upgrade to Moodle version 2.6.9, 2.7.6, or 2.8.4 or later.
What are the affected versions by CVE-2015-2267?
Affected versions include Moodle 2.5.0 to 2.5.9, 2.6.x before 2.6.9, 2.7.x before 2.7.6, and 2.8.x before 2.8.4.
Who can exploit CVE-2015-2267?
Remote authenticated users can exploit CVE-2015-2267 to bypass access restrictions.
What type of vulnerability is CVE-2015-2267?
CVE-2015-2267 is a vulnerability that allows the extraction of archives to arbitrary directories.